GNU Image Manipulation Program

用户手册

法律通告

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section enphrased GNU Free Documentation License.

修订历史
修订 $Revision: 1.144 $ 2006-03-10 romanofski

目录

I. 开始使用 GIMP
1. 简介
1. 欢迎使用 GIMP
1.1. 作者
1.2. GIMP 帮助系统
1.3. 特性和功能
2. GIMP 的新特性
2.1. 互用性和标准支持
2.2. 快捷键编辑器
2.3. 插件预览
2.4. 变换操作的实时预览
2.5. 遵循 GNOME 人机界面手册
2.6. GTK+ 2.4 整合
2.7. 基本的矢量支持
2.8. 还有...
3. 运行 GIMP
3.1. 命令行参数
3.2. 适用平台
3.3. 语言
4. 首次启动 GIMP
2. GIMP 基本概念
1. 简介
1.1. 主工具箱
1.2. 图像窗口
1.3. 对话框和停靠栏
2. GIMP 基本概念
3. 了解图像
3.1. 图像格式
3.2. 快速蒙板
3.3. 图层
3.4. 选区
3.5. 撤消
3.6. 网格和参考线
3.7. 路径
3.8. 画笔
3.9. 渐变
3.10. 图案
3.11. 色板
3.12. 文字和字体
3. 不要抓狂
1. 抓狂!
2. GIMP 没有反应的主要原因
II. 如何成为 GIMP 专家?
4. 中级概念
1. 插件
1.1. 简介
1.2. 使用插件
1.3. 安装新插件
1.4. 写插件
2. 使用 Script-Fu 脚本
5. 初级用户使用 GIMP
1. 文件
1.1. 打开文件
1.2. 保存文件
2. 对话框和停靠栏
2.1. 创建对话框
2.2. 删除页签
3. 如何设置平铺缓存
6. 中级用户使用 GIMP
1. 用法
2. 创建新图层
3. 路径
3.1. 勾画路径
3.2. 转换路径
4. 创建在网页中使用的图像
4.1. 进一步压缩文件大小
5. 添加新画笔
7. 专家级用户使用 GIMP
1. 文字和字体
1.1. 装饰文字
1.2. 添加字体
1.3. 字体问题
2. 渲染一个参考线
III. GIMP 功能参考
8. 工具箱
1. 工具箱
1.1. 工具选项
2. 选择工具
2.1. 基本特性
2.2. 矩形选择工具
2.3. 椭圆选择工具
2.4. 自由选择工具
2.5. 模糊选择工具
2.6. 按颜色选择工具
2.7. 剪刀工具
3. 笔刷工具
3.1. 基本特性
3.2. 油漆桶填充
3.3. 渐变工具
3.4. 涂画工具(铅笔,画笔和喷枪)
3.5. 铅笔工具
3.6. 画笔工具
3.7. 橡皮工具
3.8. 喷枪工具
3.9. 墨水工具
3.10. 克隆工具
3.11. 卷积工具(模糊/锐化)
3.12. 减淡或加深
3.13. 涂抹工具
4. 变换工具
4.1. 移动工具
4.2. 剪裁工具
4.3. 旋转工具
4.4. 缩放工具
4.5. 切变工具
4.6. 透视工具
4.7. 翻转工具
5. 颜色工具
5.1. 色彩平衡工具
5.2. 色调-饱和度
5.3. 单色化工具
5.4. 亮度-对比度
5.5. 阈值工具
5.6. 色阶工具
5.7. 曲线工具
5.8. 海报效果工具
6. 其它工具
6.1. 路径工具
6.2. 颜色拾取工具
6.3. 放大镜工具
6.4. 测量工具
6.5. 文字工具
7. 颜色和指示器区域
7.1. 颜色区域
7.2. 指示器区域
9. 对话框
1. 对话框简介
2. Image structure related dialogs
2.1. 图层对话框
2.2. 通道对话框
2.3. 路径对话框
2.4. 颜色表对话框
2.5. 柱状图对话框
2.6. 导航对话框
2.7. 撤销历史对话框
3. Image structure related dialogs
3.1. 颜色对话框
3.2. 画笔对话框
3.3. 图案对话框
3.4. 渐变对话框
3.5. 色板
3.6. 字体对话框
4. Image structure related dialogs
4.1. 缓冲区对话框
4.2. 文档历史对话框
5. Misc dialogs
5.1. 工具对话框
5.2. 首选项
10. 菜单
1. GIMP Menus
2. 工具箱菜单
2.1. 工具箱菜单
2.2. 获取
2.3. 首选项
2.4. 对话框
3. 扩展
3.1. 模块管理器
3.2. 单位编辑器
3.3. 插件详细信息
3.4. DB 浏览器
3.5. Script-Fu
4. 帮助
4.1. 帮助
4.2. 环境帮助
4.3. 每日提示
4.4. 关于
4.5. GIMP 在线
5. 文件
5.1. 文件
5.2. 新建
5.3. 打开
5.4. 最近打开
5.5. 保存
5.6. 另存为
5.7. 保存副本
5.8. 另存为模板
5.9. 恢复
5.10. 关闭
5.11. 退出
6. 编辑
6.1. 文件
6.2. 撤销
6.3. 重做
6.4. 撤销历史
6.5. 剪切
6.6. 复制
6.7. 可见复制
6.8. 粘贴
6.9. 粘贴进入
6.10. 粘贴为新图像
6.11. 缓冲区
6.12. 清除
6.13. 填充
6.14. 以前景色填充
6.15. 以背景色填充
6.16. 以图案填充
6.17. 勾画选区
6.18. 勾画路径
7. 查看
7.1. 查看
7.2. 新建视图
7.3. 点对点
7.4. 缩放
7.5. 紧贴
7.6. 全屏
7.7. 信息窗口
7.8. 导航窗口
7.9. 显示选区
7.10. 显示图层边界
7.11. 显示参考线
7.12. 吸附到参考线
7.13. 显示网格
7.14. 吸附到网格
7.15. 显示菜单栏
7.16. 显示标尺
7.17. 显示滚动条
7.18. 显示状态栏
8. 图像
8.1. 图像
8.2. 复制
8.3. 模式
8.4. RGB
8.5. 灰度
8.6. 索引
8.7. 变换
8.8. 翻转
8.9. 旋转
8.10. 分块
8.11. 画布大小
8.12. 缩放图像
8.13. 剪裁图像
8.14. 自动剪裁图像
8.15. 合并可见图层
8.16. 平整图像
8.17. 配置网格
9. 图层
9.1. 图层
9.2. 新建图层
9.3. 复制图层
9.4. 固定图层
9.5. 向下合并
9.6. 删除图层
9.7. 堆栈
9.8. 选择前一图层
9.9. 选择后一图层
9.10. 选择顶部图层
9.11. 选择底部图层
9.12. 升高图层
9.13. 降低图层
9.14. 图层移至顶部
9.15. 图层移至底部
9.16. 颜色
9.17. 去色
9.18. 反向
9.19. 子菜单:自动
9.20. 色调均化
9.21. 颜色增强
9.22. 蒙板
9.23. 添加图层蒙板
9.24. 应用图层蒙板
9.25. 删除图层蒙板
9.26. 蒙板到选区
9.27. 添加到选区
9.28. 从选区中减去
9.29. 与选区相交
9.30. 透明
9.31. 添加 Alpha 通道
9.32. 颜色到 Alpha
9.33. 半平整
9.34. Alpha 阈值
9.35. Alpha 到选区
9.36. 添加到选区
9.37. 从选区中减去
9.38. 与选区相交
9.39. 变换
9.40. 水平翻转
9.41. 水平(垂直)翻转
9.42. 顺时针旋转 90 度
9.43. 逆时针旋转 90 度
9.44. 逆时针旋转 180 度
9.45. 任意旋转
9.46. 位移
9.47. 图层边界大小
9.48. 图层到图像大小
9.49. 缩放图层
10. 工具
10.1. 工具
11. 滤镜
11.1. 滤镜
11.2. 重复上次
11.3. 调出上次
11.4. 重置所有滤镜
11. 滤镜
1. 滤镜概述
2. 模糊滤镜
2.1. 模糊滤镜简介
2.2. 模糊
2.3. 高斯模糊
2.4. 选择性高斯模糊
2.5. 动态模糊
2.6. 像素化
3. 颜色滤镜
3.1. 通道混合器
3.2. 色系分析
3.3. 单色化
3.4. 颜色到 Alpha
3.5. 合成
3.6. 燥点
3.7. 半平整
3.8. 平滑色板
4. 噪音滤镜
5. 边缘检测滤镜
5.1. Sobel
6. 增强滤镜
7. 通用滤镜
7.1. 通用滤镜简介
8. 玻璃效果滤镜
9. 光线效果滤镜
9.1. 光线效果滤镜简介
9.2. 闪光
9.3. 火花
9.4. 超新星
10. 扭曲滤镜
11. 艺术滤镜
11.1. 艺术滤镜概述
11.2. 使用画布
11.3. 立体派
11.4. 油画
12. 绘制滤镜
12.1. 绘制滤镜简介
12.2. Plasma
12.3. 纯色噪音
12.4. 火焰
12.5. IFS 分形
12.6. 网格
12.7. 迷宫
12.8. 拼图
12.9. QBist
12.10. 正弦
13. 组合滤镜
13.1. 组合滤镜简介
13.2. 深度合并
13.3. 胶卷
术语表
参考资料
A. GIMP 的历史
1. The very beginning
2. The early days of GIMP
3. The One to change the world
B. Bugs 报告与功能加强要求
1. 确认是个 Bug
2. 报告 Bug
3. 提交 Bug 后该怎么办
C. GNU 自由文档许可证
D. 哎呀!掉了帮助文件

插图清单

1.1. 欢迎
1.2. 个人 GIMP 目录
1.3. 用户安装日志
1.4. GIMP 性能调节
2.1. 该屏幕截图是 GIMP 的标准窗口
2.2. 工具箱的屏幕截图
2.3. 一个图像窗口的屏幕截图包含了其重要元素
2.4. 一个停靠栏,其停靠条高亮
2.5. 一个停靠栏中的对话框,其拖动臂点区域高亮
2.6. 一个图像菜单高亮的停靠栏
2.7. 一个停靠栏中的一个对话框,其页签菜单按钮高亮
2.8. 图层对话框中的页签菜单
2.9. 页签菜单的预览大小子菜单。
2.10. 页签菜单的页签风格子菜单
2.11. Image with QuickMask enabled
2.12. 如何把这个树独立出来?
2.13. 选区通常用虚线表示
2.14. 在快速蒙板模式下的同一个选区
2.15. 羽化后在快速蒙板模式下的同一个选区
2.16. 该图像在下面的例子中使用
2.17. 带默认网格的图像
2.18. 一个不同的网格样式
2.19. 带四个参考线的图像
2.20. GIMP 路径的四个例子
2.21. 一个正在用路径工具处理的路径,黑色正方形是锚点,开启的圆形是选中的锚点,而两个空心的正方形是它的臂点。主要该路径有两部分。
2.22. Text converted to a path
2.23. Brush strokes example
2.24. 一些 GIMP 渐变的范例。
2.25. Gradient usage
2.26. Pattern usage
2.27. Pattern script examples
2.28. 色板对话框
2.29. 色板编辑器
2.30. 颜色表对话框
2.31. Example of a text item
2.32. GIMP text editor
3.1. 有一个浮动选区的对话框。
3.2. Unstuck show selection menu
3.3. Unstuck select all
3.4. Unstuck layer invisibility
3.5. Unstuck layer transparency
5.1. “打开文件”对话框
5.2. “打开位置”对话框
5.3. 导出对话框范例
5.4. 一个停靠栏中的对话框,其“关闭页签”按钮高亮。
6.1. 用不同方式勾画的最上面图中四个路径。
6.2. 索引图像看上去可能上面有点纹理。左边图像是 Wilber 原始大小,而右边是放大为百分之 300。
7.1. Fancy text
8.1. 矩形选择工具的工具选项对话框。
8.2. 工具箱中的矩形选择图标
8.3. 矩形选择工具的工具选项
8.4. 矩形选择工具的大小限制菜单
8.5. 工具箱中的椭圆选择图标
8.6. 椭圆选择工具的工具选项
8.7. 椭圆选择工具的大小限制菜单
8.8. 工具箱的自由选择图标
8.9. 自由选择工具的工具选项
8.10. 工具箱中魔术棒工具图标
8.11. 魔术棒工具的工具选项
8.12. 工具箱中的按颜色选择工具图标。
8.13. 按颜色选择工具的工具选项
8.14. 工具箱中智能剪刀工具图标。
8.15. 智能剪刀的工具选项
8.16. 笔刷工具
8.17. 所有笔刷工具共享的工具选项
8.18. Toolbox Fill
8.19.
8.20. Painting example
8.21. Dissove mode example
8.22. 涂画工具的渐变选项。
8.23. Pencil tool
8.24. Paintbrush
8.25. 工具箱中的橡皮工具图标
8.26. 橡皮工具的工具选项
8.27. The Airbrush tool in Toolbox
8.28. Toolbox Pen
8.29. 工具栏中的克隆工具图标
8.30. 克隆工具的工具选项
8.31. 工具箱中卷积工具图标
8.32. 卷积工具的工具选项
8.33. Dodge tool
8.34. Smudge tool
8.35. The Move tool in Toolbox
8.36. Crop tool
8.37. The Rotate tool in Toolbox
8.38. The Scale tool in Toolbox
8.39. The Shear tool in Toolbox
8.40. Perspective tool
8.41. Flip tool
8.42. Color Balance options
8.43. Hue-Saturation tool options
8.44. Colorize options
8.45. Threshold tool options
8.46. Level tool options
8.47. Curves tool
8.48. Posterize tool options
8.49. Path tool
8.50. Eye dropper
8.51. Zoom tool
8.52. Measure tool
8.53. The Text tool in Toolbox
8.54. Color area in the Toolbox Palette
8.55. Active tool indicator area
9.1. Layer Dialog
9.2. 图层模式
9.3. 保持透明部分
9.4. 不透明度
9.5. Dialog add mask
9.6. The Channel dialog
9.7. 一个带通道图像的表现
9.8.
9.9. 路径对话框
9.10. 路径对话框菜单
9.11. 颜色表对话框
9.12. 柱状图对话框
9.13. 一个带 Alpha 通道的图层的通道选项。
9.14. 将红色,绿色和蓝色通道结合。
9.15. 上面的柱状图用对数模式显示。
9.16. 在设定一个范围后的显示。
9.17. Navigation Dialog
9.18. 撤销历史对话框
9.19. Colors dialog
9.20. 画笔对话框
9.21. 画笔对话框
9.22. 图案对话框
9.23. 图案对话框(列表模式)
9.24. 渐变对话框
9.25. 渐变编辑器对话框
9.26. 渐变编辑器菜单
9.27. “加载颜色自” 子菜单
9.28. 混合函数子菜单
9.29. 着色类型子菜单
9.30. 色板对话框
9.31. 色板对话框(阵列模式)
9.32. 色板菜单
9.33. 导入色板对话框
9.34. 色板编辑器
9.35. 色板编辑器菜单
9.36. 字体对话框
9.37. 字体对话框(以阵列方式查看)
9.38. 缓冲区对话框
9.39. 缓冲区对话框(阵列模式)
9.40. 缓冲区菜单
9.41. 工具对话框
9.42. 首选项页列表
9.43. 新建图形首选项
9.44. 默认网格首选项
9.45. 分类界面首选项
9.46. 主题首选项
9.47. 帮助系统首选项
9.48. 工具选项首选项
9.49. 工具箱首选项
9.50. 默认工具项外观
9.51. 常规图像窗口首选项
9.52. 图像窗口默认外观
9.53. 图像窗口标题和状态格式
9.54. 显示首选项
9.55. 定调对话框。
9.56. 窗口管理首选项
9.57. 环境首选项
9.58. 基本文件夹首选项
9.59. 首选项:画笔文件夹
10.1. Toolbox Menu
10.2. 文件菜单内容
10.3. 新建图像对话框
10.4. 模板菜单(默认值)
10.5. 新建图像对话框(高级选项)
10.6. 颜色表菜单
10.7. 填充菜单
10.8. Open Dialog
10.9.
10.10. 编辑/缓冲区
10.11. 选项
10.12. 选项
10.13. 斜接限制
10.14. 查看菜单内容
10.15. 查看菜单的缩放子菜单
10.16. 信息窗口
10.17. 扩展页签
10.18. 图像菜单内容
10.19. 图像菜单的模式子菜单
10.20. Options
10.21. Example full color no dithering
10.22. Example 4 colors no dithering
10.23. Example Floyd-Steinberg (normal)
10.24. Example Floyd-Steinberg 4 colors
10.25. 图像/变换
10.26. Dialog canvas size
10.27. Dialog Image Scale
10.28. Options
10.29. 平整图像菜单 item.
10.30. Dialog configure grid
10.31. 图层菜单
10.32. 新建图层对话框
10.33. 堆栈子菜单
10.34. 颜色子菜单
10.35. 颜色/自动子菜单
10.36. 图层菜单的蒙板子菜单
10.37. “添加图层蒙板”对话框
10.38. 图层菜单透明子菜单
10.39. “Alpha 阈值”对话框
10.40. 图层菜单的变换子菜单
10.41. “位移”对话框
10.42. 工具菜单内容
10.43. 滤镜菜单
11.1. 范例的原始图像
11.2. 高斯模糊(半径 10)
11.3. 简单模糊
11.4. 选择性模糊
11.5. 像素化
11.6. 动态模糊
11.7. Options Gaussian Blur
11.8. 选项
11.9. Oilify” filter options
11.10. 绘制的 Plasma 的范例。
11.11. 弥散纯色噪音范例。
11.12. 绘制火焰范例。
11.13. 编辑火焰对话框
11.14. 绘制的迷宫的一个范例
11.15. Jigsaw filter example
11.16. 三个随机的 Qbist 绘制的范例。
11.17. 正弦绘制的范例。
223. JPEG 保存对话框

表格清单

8.1. “Abstract 2”渐变的三种渐变重复模式。